Issues MSFT Teams & Outlook

Incident Report for Fireflies

Update

We are continuing to investigate this issue.
Posted Nov 25, 2020 - 17:57 PST

Investigating

MSFT Teams & Outlook is having issues upstream. We are investigating and hope to get it back to 100% uptime soon.
Posted Nov 25, 2020 - 17:53 PST